help.png

for  Technical Support please email  support@dowtindesign.com

 

 

 

 

FAQ's

 

DeskyEarth

What are the System Requirements for DeskyEarth?

  •  a 2009 or greater Mac/iMac/MacBook with NVIDIA or AMD graphics
 
 
Does DeskyEarth work with OSX 10.9 ( Mavericks)?
  • Yes. DeskyEarth is developed and tested on a Mavericks Mac